keywords: ip pbx voip gateway gsm gateway



The forum is in read only mode.
× Questions about VS-GW2120/GW1600/GW1202 and WGW1002G GSM Series VoIP Gateway

DTMF problem with OpenVox VS-GW1600

11 years 4 days ago #8878 by glk
I have recently purchased a OpenVox VS-GW1600-12G VoxStack GSM Gateway.

I’ve configured that to receiving calls on its GSM channels and route the incoming calls to an external SIP server (the VS-GW1600 is registered to that SIP server as client). Audio communication is absolutely fine, when calls are forwarded to SIP phones, but when we try to use DTMF the codes are not recognized.

We’ve set G.729 codec and we’ve tried with any of the available DTMF options without any success.

Could you advice how we can solve that DTMF issue as it’s blocking us from using the gateway ?
11 years 4 days ago #8879 by svolta
We have solved this problem,you need upgrade your firemware,Please click this link

to download new firmware.and then upgrade your firmware of "GSM Gateway".By the way,you need factary reset your "GSM Gateway" when you finish upgrade.
11 years 3 days ago #8880 by glk

Thanks for the reply. We've upgraded the firmware, but it seems there still is an issue with G.729 codec. In fact there are packets lost or delayed when we try to use DTMF making the communication impossible.

On the other hand using G.726 the DTMF (info) works, But this is not enough, as the other side accepts only G.729.

Could you advice further on the issue ?
11 years 3 days ago #8881 by Denins.Den
Did you do factory reset yet? By the way, you need to do factory reset in every single module, for example:
the first module you can use 80 port to access in with web browser, the second use port 81 ......
Please comfirm this.
11 years 3 days ago #8882 by glk
We've set the modules at stand-alone mode and we've installed (and tested) sims only on the 1st module.
We've tried Factory Reset on the 1st Module using the web interface (System > Tools > Restore Configuration > Factory Reset).
Isn't that enough ??
11 years 3 days ago #8884 by glk
Since my last message, we've upgraded the firmware to all the modules and set the Factory default settings.

Following that, we've configured the modules in Cluster mode (1st one as Master and the rest as Slaves).

We've configured again SIP settings and Codecs, but unfortunately DTMF (both RFC2833 and Info) does not work with G.729.

It seems that packets are lost (or delayed in both directions), because not only the codes we've sent are not recognized, but also the IVR prompts are broken and in some cases we listen the broken parts (we should listen before we send the DTMFs) after the DTMF codes have been sent. Note that we've already tried 2 different IVR platforms and the results are the same.

Is it any other configuration settings we should take care off?
Time to create page: 0.037 seconds
Powered by Kunena Forum